TodoToday for Zoho Projects does not sync with Two Factor Autentication

Problem


Login to TodoToday for Zoho Projects with the Zoho username and password is successful but no tasks are shown in TodoToday. Zoho user account is configured for Two Factor authentication.

Cause


TodoToday for Zoho Projects does not currently directly support the two factor authentication.

Workaround 


To login and sync TodoToday with Zoho Projects you need to generate an Application Specific Password from the Zoho Two Factor Authentication Settings. 
  1. Go to the Zoho Accounts Two Factor Authentication Setttngs
  2. Select the Application Specific Passwords option
  3. Enter a Device (or) App Name, e.g. "TodoToday on Nexus 4" and generate the password.  If you have TodoToday installed on multiple devices it's recommended to generate a separate password per device.
  4. Go the the Settings in TodoToday and select the user account and select Update account credentials to enter the new password
  5. Tasks from Zoho Projects should now start to sync.


Feedback and Knowledge Base